[Erledigt] Umlaute in IPTC-Daten

Alles rund um AquaSoft DiaShow 10 - bitte beachten Sie die Forenregeln und die Nettiquette
Antworten
khg1
Mega-Poster
Mega-Poster
Beiträge: 457
Registriert: Di Sep 28, 2010 16:58

[Erledigt] Umlaute in IPTC-Daten

Beitrag von khg1 » Mo Jan 11, 2016 20:18

In Feldern wie z.B. %IPTCImageHeadline% werden Umlaute, Akzente u.ä. i Layoutdesigner/Texteditior falsch, d.h. als nicht druckbares Zeichen in Form eines Quadrats dargestellt. In Lightroom und anderen Programmen werden die Zeichen jedoch richtig dargestellt.

Wenn ich den Text aus dem Ausgangsprogramm mit Copy/Paste übernehme, werden die Zeichen jedoch richtig wieder gegeben.
Viele Grüße
Gerd
_______________________
Stages 11, Windows 10, 64 bit, Intel i-5-8400, 16 GB, Nvida GTX 1060 6GB, Samsung TV UE55JU7090TXZG

mandler2010
Dauerposter
Dauerposter
Beiträge: 56
Registriert: Mo Jan 25, 2010 15:52

Re: Umlaute in IPTC-Daten

Beitrag von mandler2010 » Mo Jan 11, 2016 22:54

Hallo khg1,
ich habe das auch schon bemängelt. Habe es dem Support weitergegeben. Wenn ich im normalen Textfeld für einzelen Bilder einen Text eingebe erscheint ja der Rahmen den man an beliebiger Stelle setzen kann. Da sind die Umlaute richtig bei meinen 3 Schriften die wahlweise nutze. Bei einer Texteingabe über die IPTC-Daten ist der Text (Bildbeschreibung) ja schon vorhanden. Bei mir ist es so das dieser Text auch in den in den Textrahmen geschrieben wird. Bei der 7, 8, und 9 Version ist es so das dieser Text direkt ins Bild geschrieben wird. Ich benutze immer Datum, Uhrzeit und in der 2. Zeile meine Bildbeschreibung. Falls ich mal keine Bildbeschreibung ( %exifimagedescription% ) springen Datum und Uhrzeit automatisch nach unten. Ausrichten vom Text mache ich immer links, sowie Direkt unter Bild. Das klappt zur Zeit auch nicht. Dies klappt mit Bildern im 3:2 und auch mit 16:9. Wohin bei mir im 3:2 links und rechts ein schwarze Streifen sind die man ja farbig nach seinem Geschmack ändern kann.
mfg.
Franz

khg1
Mega-Poster
Mega-Poster
Beiträge: 457
Registriert: Di Sep 28, 2010 16:58

Re: Umlaute in IPTC-Daten

Beitrag von khg1 » Di Jan 12, 2016 10:34

Ergänzung zu meiner Fehlermeldung:

In Diashow 9 werden die Umlaute, Akzente etc. richtig angezeigt.
Unbenannt2.JPG
Diashow 9
Unbenannt.JPG
Diashow 10
Viele Grüße
Gerd
_______________________
Stages 11, Windows 10, 64 bit, Intel i-5-8400, 16 GB, Nvida GTX 1060 6GB, Samsung TV UE55JU7090TXZG

Benutzeravatar
Kerstin Thaler
Moderator
Moderator
Beiträge: 2415
Registriert: Mo Jan 29, 2007 12:40
Kontaktdaten:

Re: Umlaute in IPTC-Daten

Beitrag von Kerstin Thaler » Di Jan 12, 2016 10:54

Wir können den Fehler hier nicht reproduzieren.
Vielleicht können Sie unserem Support das betreffende Nasenbärbild zur Anylyse zusenden.

Wird denn der Text in der Meta-Daten-Ansicht korrekt dargestellt?
Mit freundlichen Grüßen
Kerstin Thaler
AquaSoft

Bild

khg1
Mega-Poster
Mega-Poster
Beiträge: 457
Registriert: Di Sep 28, 2010 16:58

Re: Umlaute in IPTC-Daten

Beitrag von khg1 » Di Jan 12, 2016 11:13

In der Metadatenansicht werden die Texte im Abschnitt XMP (z.B. title, description) korrekt wiedergegeben, im Abschnitt IPTC nicht.

Ein Beispielbild schicke ich an den Support.
Viele Grüße
Gerd
_______________________
Stages 11, Windows 10, 64 bit, Intel i-5-8400, 16 GB, Nvida GTX 1060 6GB, Samsung TV UE55JU7090TXZG

Benutzeravatar
Kerstin Thaler
Moderator
Moderator
Beiträge: 2415
Registriert: Mo Jan 29, 2007 12:40
Kontaktdaten:

Re: Umlaute in IPTC-Daten

Beitrag von Kerstin Thaler » Di Jan 12, 2016 11:39

Vielen Dank!
Mit freundlichen Grüßen
Kerstin Thaler
AquaSoft

Bild

Benutzeravatar
Steffen Binas
Moderator
Moderator
Beiträge: 3244
Registriert: Mi Mär 26, 2003 22:53
Kontaktdaten:

Re: Umlaute in IPTC-Daten

Beitrag von Steffen Binas » Mi Jan 13, 2016 14:22

In dem Bild, sind die Beschriftungen falsch in den Metadaten abgespeichert. Sie sind mit UTF8 kodiert aber als ASCII abgespeichert. Es gibt scheinbar Programme, die die Daten falsch in die JPEGs schreiben. Wir haben für das nächste Update einen Mechanismus integriert, der die Kodierung auch in einem solchen Fall korrekt ermittelt.
In der DiaShow 9 hatten wir noch einen anderen EXIF/IPTC-Reader und damals auch bereits einen ähnlichen Workaround integrieren müssen.
MfG Steffen Binas, AquaSoft

Neuste Infos gewünscht? Folgen Sie uns auf Twitter: http://twitter.com/aquasoft_de
Bild

khg1
Mega-Poster
Mega-Poster
Beiträge: 457
Registriert: Di Sep 28, 2010 16:58

Re: Umlaute in IPTC-Daten

Beitrag von khg1 » Mi Jan 20, 2016 18:07

In 10.0.11 erledigt.
Viele Grüße
Gerd
_______________________
Stages 11, Windows 10, 64 bit, Intel i-5-8400, 16 GB, Nvida GTX 1060 6GB, Samsung TV UE55JU7090TXZG

roka
Einsteiger
Einsteiger
Beiträge: 2
Registriert: Sa Mär 26, 2016 12:39

Re: [Erledigt] Umlaute in IPTC-Daten

Beitrag von roka » Sa Mär 26, 2016 14:01

Funktioniert bei mir leider weder in der 10.0.11 noch in der 10.1.01.

Ich verwende für die Bildbeschriftung ausgiebig die Variable %EXIFImageDescription%, was in der Ultimate 9 wunderbar funktionierte.
Die Texte wurden über eine Funktion des Bildbearbeitungsprogramms Fixfoto eingebracht. Die Umlaute werden dort, von ACDSee und weiteren Bildbetrachtern und EXIF-Utilities, und besonders auch im Windows Datei-Explorer korrekt dargestellt.

Eine Beispieldatei ist beigefügt. Statt "ä ö ü Ä Ö Ü ß @ €" wird von Ultimate 10 dargestellt: "d v | D V \ _ @ "

Ich kenne die Problematik der String-Umwandlung (char wchar bstring ASCII UTF8/UTF16 etc.) aus eigener Programmiertätigkeit, und hoffe sehr, dass Aquasoft in einem der nächsten Updates wieder eine saubere Umlaut-Darstellung für alle Varianten der Metadatencodierung gelingt.

MfG,
Ronald
Dateianhänge
150704_01008_klein.JPG

Benutzeravatar
Nadine
Moderator
Moderator
Beiträge: 881
Registriert: Do Jul 21, 2011 11:18

Re: [Erledigt] Umlaute in IPTC-Daten

Beitrag von Nadine » Sa Mär 26, 2016 19:30

Es würde uns helfen, wenn Sie ads-Datei und Bild direkt an den Support senden könnten (support@aquasoft.de).
Viele Grüße, Nadine aus dem AquaSoft-Team


roka
Einsteiger
Einsteiger
Beiträge: 2
Registriert: Sa Mär 26, 2016 12:39

Re: [Erledigt] Umlaute in IPTC-Daten

Beitrag von roka » Di Mai 17, 2016 15:03

Mit der neuen Version 10.2.01 (64 bit) ist das Problem gelöst.
Ich bekomme jetzt in der Bildbeschriftung genau das, was ich in der Bildatei als EXIF-Beschreibung hinterlegt habe, die Umlaute sind jetzt korrekt.

Danke für die zeitnahe Behebung!

Antworten